i have trouble with dhcp work under bridged vlans
Some at logs without success some can’t get ips at all with no warning
/接口桥vlan打印/出口/接口terface dhcp-server print /ip address print
/interface bridge add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \ disabled=no forward-delay=15s l2mtu=65535 max-message-age=20s mtu=1508 \ name="bridge1" priority=0x8000 protocol-mode=rstp \ transmit-hold-count=6 /interface bridge port add bridge="bridge1" disabled=no edge=auto external-fdb=auto horizon=\ none interface=lan1 path-cost=10 point-to-point=auto priority=0x80 add bridge="bridge1" disabled=no edge=auto external-fdb=auto horizon=\ none interface=vlan1 path-cost=10 point-to-point=auto priority=0x80 add bridge="bridge1" disabled=no edge=auto external-fdb=auto horizon=\ none interface=vlan2 path-cost=10 point-to-point=auto priority=0x80 add bridge="bridge1" disabled=no edge=auto external-fdb=auto horizon=\ none interface=vlan3 path-cost=10 point-to-point=auto priority=0x80 add bridge="bridge1" disabled=no edge=auto external-fdb=auto horizon=\ none interface=vlan99 path-cost=10 point-to-point=auto priority=0x80 /interface bridge settings set use-ip-firewall=yes use-ip-firewall-for-pppoe=no \ use-ip-firewall-for-vlan=yes # NAME MTU ARP VLAN-ID INTERFACE 0 R vlan1 1508 enabled 1 lan1 1 R vlan2 1508 enabled 2 lan1 2 R ;;; Cable vlan3 1508 enabled 3 lan1 3 R w-2-BR 1508 enabled 4 lan1 3 R ;;; Devices vlan99 1500 enabled 99 lan1 # NAME INTERFACE RELAY ADDRESS-POOL LEASE-TIME ADD-ARP 0 DHCP bridge1 LAN_POOL1 3d yes # ADDRESS NETWORK INTERFACE 0 ;;; WAN xxx.xxx.xxx.xxx/24 xxx.xxx.xxx.0 wan1 1 ;;; LAN 10.10.10.1/24 10.10.10.0 lan1
/interface bridge port add bridge="bridge1" disabled=no edge=auto external-fdb=auto horizon=\ none interface=lan1 path-cost=10 point-to-point=auto priority=0x80 add bridge="bridge1" disabled=no edge=auto external-fdb=auto horizon=\ none interface=vlan1 path-cost=10 point-to-point=auto priority=0x80 add bridge="bridge1" disabled=no edge=auto external-fdb=auto horizon=\ none interface=vlan2 path-cost=10 point-to-point=auto priority=0x80 add bridge="bridge1" disabled=no edge=auto external-fdb=auto horizon=\ none interface=vlan3 path-cost=10 point-to-point=auto priority=0x80 add bridge="bridge1" disabled=no edge=auto external-fdb=auto horizon=\ none interface=vlan99 path-cost=10 point-to-point=auto priority=0x80
/接口桥vlan打印/出口/接口terface dhcp-server print /ip address print
/ip firewall filter add chain=forward in-interface=vlan1 out-interface=vlan2 action=drop add chain=forward in-interface=vlan2 out-interface=vlan1 action=drop
interface bridge filter add in-interface="LAN-bridge" out-interface="LAN-bridge" action=drop
/interface vlan add name=VLAN002 vlan-id=2 disabled=no interface=ether5 /interface bridge add name="LAN-bridge" /interface bridge port add bridge="LAN-bridge" interface=VLAN002 horizon=1 add bridge="LAN-bridge" interface=ether4 horizon=1
/interface vlan add name=VLAN002 vlan-id=2 disabled=no interface=ether5 /interface bridge add name="LAN-bridge" /interface bridge port add bridge="LAN-bridge" interface=VLAN002 horizon=1 add bridge="LAN-bridge" interface=ether5 horizon=1
Can you explain why things "break down very very quickly" further?When you bridge several VLANs together (especially when they share the same physical port) you need to set up a filter to block them from talking to each other. Without it things break down very very quickly and stop working altogether.
/接口以太网组0 arp = auto-negotia启用tion=yes disabled=no full-duplex=yes l2mtu=1526 \ mac-address=00:0C:42:5A:F3:45 mtu=1500 name=ether1-Nanostation speed=\ 100Mbps set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \ disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5A:F3:46 \ master-port=none mtu=1500 name=ether2-Bure speed=100Mbps set 2 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \ disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5A:F3:47 \ master-port=none mtu=1500 name=ether3-Switch speed=100Mbps set 3 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \ disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5A:F3:48 \ master-port=none mtu=1500 name=ether4-SDSL-Univ speed=100Mbps set 4 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited \ disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5A:F3:49 \ master-port=none mtu=1500 name=ether5-ADSL-MWeb speed=100Mbps /interface bridge add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \ disabled=no forward-delay=15s l2mtu=1520 max-message-age=20s mtu=1500 \ name=bridge-SCN priority=0x8000 protocol-mode=none transmit-hold-count=6 /interface bridge port add bridge=bridge-SCN disabled=no edge=auto external-fdb=auto horizon=none \ interface=ether2-Bure path-cost=10 point-to-point=auto priority=0x80 add bridge=bridge-SCN disabled=no edge=auto external-fdb=auto horizon=none \ interface=ether1-Nanostation path-cost=10 point-to-point=auto priority=\ 0x80 add bridge=bridge-SCN disabled=no edge=auto external-fdb=auto horizon=none \ interface=vlan-L1 path-cost=10 point-to-point=auto priority=0x80 /interface bridge settings set use-ip-firewall=yes use-ip-firewall-for-pppoe=yes \ use-ip-firewall-for-vlan=yes /interface vlan add arp=enabled disabled=no interface=ether3-Switch l2mtu=1520 mtu=1500 name=\ vlan-L3 use-service-tag=no vlan-id=2 add arp=enabled disabled=no interface=ether3-Switch l2mtu=1520 mtu=1500 name=\ vlan-L1 use-service-tag=no vlan-id=1 add arp=enabled disabled=no interface=ether3-Switch l2mtu=1520 mtu=1500 name=\ vlan-L2 use-service-tag=no vlan-id=4 add arp=enabled disabled=no interface=ether3-Switch l2mtu=1520 mtu=1500 name=\ vlan-L4 use-service-tag=no vlan-id=3 /ip dhcp-server add address-pool=default-dhcp authoritative=after-2sec-delay bootp-support=\ static disabled=no interface=vlan-L3 lease-time=3d name=dhcp-LAN-WiFi add address-pool=dhcp-switch authoritative=after-2sec-delay bootp-support=\ static disabled=no interface=ether3-Switch lease-time=3d name=\ dhcp-LAN-Switch add address-pool=pool-vlan2 authoritative=after-2sec-delay bootp-support=\ static disabled=no interface=vlan-L2 lease-time=3d name=dhcp-L2 add address-pool=pool-vlan4 authoritative=after-2sec-delay bootp-support=\ static disabled=no interface=vlan-L4 lease-time=3d name=dhcp-L4 /ip dhcp-server network add address=192.168.90.0/24 comment="LAN - WiFi" dns-server=192.168.90.1 \ domain=tuis gateway=192.168.90.1 add address=192.168.91.0/24 comment="LAN - Switch" dns-server=192.168.91.1 \ domain=tuis gateway=192.168.91.1 add address=192.168.100.0/24 comment=VLAN-L2 dns-server=192.168.100.1 domain=\ tuis gateway=192.168.100.1 add address=192.168.101.0/24 comment=VLAN-L4 dns-server=192.168.101.1 domain=\ tuis gateway=192.168.101.1 /ip address add address=192.168.90.1/24 comment="LAN - WiFi" disabled=no interface=\ vlan-L3 network=192.168.90.0 add address=10.20.60.123/24 comment=SCN disabled=no interface=bridge-SCN \ network=10.20.60.0 add address=192.168.89.254/32 comment="Nanostation @ 192.168.89.2" disabled=\ no interface=ether1-Nanostation network=192.168.89.2 add address=146.xx.xx.xx/25 comment="SDSL routers @ 146.xx.xx.xx-xx" \ disabled=no interface=ether4-SDSL-Univ network=146.xx.xx.0 add address=192.168.89.254/32 comment="D-ink ADSL router @ 192.168.89.1" \ disabled=no interface=ether5-ADSL-MWeb network=192.168.89.1 add address=192.168.89.254/32 comment="D-ink WiFi AP @ 192.168.89.3" \ disabled=no interface=ether3-Switch network=192.168.89.3 add address=192.168.91.1/24 comment="LAN - Switch" disabled=no interface=\ ether3-Switch network=192.168.91.0 add address=192.168.0.101/24 disabled=yes interface=vlan-L3 network=\ 192.168.0.0 add address=192.168.100.1/24 comment="LAN - L2" disabled=no interface=vlan-L2 \ network=192.168.100.0 add address=192.168.101.1/24 comment="LAN - L4" disabled=no interface=vlan-L4 \ network=192.168.101.0