The Wiki manual is not clear to me so I need some help/advices.
Situation:
client with CPE has wireless connection to AP.
AP has wireless backhaul to next wireless node.
This last wireless node connectect by cable to main gateway (border router)
Client uses VOIP device with separate IP or Skype phone with separate IP.
(Use separate IP make identification of voice communication very simple. Just the IP address of the device.)
In CPE I make mangle:
/ip firewall mangle
add action=mark-connection chain=prerouting comment="VOIP conn marker" disabled=no \
new-connection-mark=VOIP passthrough=yes src-address=172.25.53.244
add action=change-dscp chain=prerouting comment="VOIP conn get TOS 7 " connection-mark=VOIP disabled=no new-dscp=7
add action=set-priority chain=prerouting comment="TOS 7 mark get priority 7" disabled=no dscp=7 new-priority=7 passthrough=no
add action=mark-packet chain=forward comment="TOS 7 Traffic get conn mark \"U-High\"" disabled=no dscp=7 new-packet-mark=U_HIGH passthrough=no
add action=mark-packet chain=forward comment="" connection-mark=U_high disabled=no new-packet-mark=U_HIGH passthrough=no
On the wireless interface WMM is enabled.
Is this now the right procedure?
1. mangle traffic from srce address and give conn. mark "U_high"
2. conn. with "U_high" mark gives all packages dscp number 7 (is highest)
3. packages with dscp=7 all get priority 7 (is highest)
4. conn. with U_high" mark gives all packages a package mark "U_HIGH" for local Queue (Where it gets highest priority.
Please some advices since I want to implement it on my network but am not sure if this is the way to go.