This is also present in 7.10b. Just noticed this the other day after upgrading a couple routers to 7.9.Bug in webfig still persists: Toggle WiFi Interface off, then on. It stays greyed out even if it got enabled. This applies to all toggable rows in any config area.
:local MODEL [/system resource get board-name] :do { :if ([:len [/file find type="backup" ]] > 0) do={ :foreach FILE in=[/file find name~"$MODEL.*" && type="backup" ] do={ :local oldBackupFilename [/file get $FILE name]; / file remove "$oldBackupFilename" :log info message="Deleted Old Backup File--$oldBackupFilename"; } } }
But did you install it on all those machines without waiting even if it was stable or if a problem came up?workx
And the rest?It seems my backup script not work well
[...]
:foreach item in=[/file find where name~"^$[/system resource get board-name]" and type="backup"] do={ :log info message="Deleted Old Backup File: $[/file get $item name]" /file remove $item }
:foreach item in=[/file find where name~"^$[/system identity get name]" and type="backup"] do={ :log info message="Deleted Old Backup File: $[/file get $item name]" /file remove $item }
Thank you for that.And the rest?It seems my backup script not work well
[...]
What's the use of the ":do {" at the beginning of the script?
Put "RB5009UPr+S+" inside a "~" create a new RegEx: "RB5009UPr+S+.*"...
so the file name searched is like
RB5009UP{one or more r}{one or more S}{any characters here}
and the + disappear from string.
For do the correct search the regexp must be writed:
RB5009UPr\+S\+.*
This works and is less complicated, but suffer the same "+" problem:Code:Select all:foreach item in=[/file find where name~"^$[/system resource get board-name]" and type="backup"] do={ :log info message="Deleted Old Backup File: $[/file get $item name]" /file remove $item }
Hint: Use RouterBOARD name instead of the RouterBOARD model.Code:Select all:foreach item in=[/file find where name~"^$[/system identity get name]" and type="backup"] do={ :log info message="Deleted Old Backup File: $[/file get $item name]" /file remove $item }
You can control how you call the device, bout you can't control the RouterBOARD name...
"$MODEL.*" ==> "$MODEL . "-" . *"
I dont think so. That will be included in 7.10 stable release !....
Would've been nice to have the "fixes" from 7.10beta5 in this release.
I don't think so.I dont think so. That will be included in 7.10 stable release !....
Would've been nice to have the "fixes" from 7.10beta5 in this release.
Mainwhile i got "MAC@wifi1 disconnected, key handshake timeout, signal strength -74" errors into console on my AX3 and devices not connecting to it. Someone with fix for this problem?
It was applied to all releases that MT considers stable or long term: 6.48, 6.49 and 7.9 ... if there are reasons for any particular user not to use one of these releases, then it really isn't up to MT to patch the rest (if it was up to MT, then everybody would either use one of stable releases or latest beta which is AFAIK patched as well). After all, the vulnerability is a problem in specific cases and not all devices are used in those cases. Default config is not vulnerable for example and I guess many users use their devices with default config (as far as this vulnerability goes).I don't suppose applying this cve fix (only) to some (one??) of the versions people are currently having to roll back too is an option?
Is this on purpose...? WPA is like near-no security.Im using only WPA/WPA2.
Tryed also 7.10b8 but same problem. Wifi devices refused to connect to AX3. Back to 7.8 stable. Waitning for new update!The error message you show, I've seen as well. Other wifi issues I've encountered are related to PMKSA or clients simply not being able to connect anymore (password prompt even for a known network and nothing further).
Some issues are solved with 7.10b5 (now b8).
There are alpha versions around for some users to address yet other wifi issues (but which issues exactly they address, is not clear).
So we need to wait for another beta, I guess, which will then move later on to stable.
Moving down to 7.8 is also an option.
I'm unable to upgrade to the latest release on my hAP ac3 - the router downloads the image, reboots itself, but loads the older version 7.9.
It's in 7.10beta. So the wait is almost over :)BFD support would be nice
Unfortunately no…I'm unable to upgrade to the latest release on my hAP ac3 - the router downloads the image, reboots itself, but loads the older version 7.9.
After router reboots after failed upgrade, is there anything in log about it?
/ipv6 settings set disable-ipv6=yes
Unfortunately no…After router reboots after failed upgrade, is there anything in log about it?
it seems clear. easy to understand...but...THIS RELEASE CONTAINS ONLY ONE THING
IT IS IN THE CHANGELOG
# Create a loopback interface (bridge without ports) /interface bridge add arp=disabled name=loopback protocol-mode=none # Add one /32 address to the loopback /ip address add address=10.10.10.10 interface=loopback network=10.10.10.10 # Add another lower /32 address to the loopback, in the disabled state /ip address add address=10.10.10.9 disabled=yes interface=loopback network=10.10.10.9 # Create a new router-id with criteria to only select the lowest ACTIVE static address from the loopback interfaces /routing id add disabled=no name=id-1 select-dynamic-id=only-static,only-loopback,only-vrf,only-active,lowest # See the selected address ... ooops!!! /routing id print where name=id-1 Columns: NAME, DYNAMIC-ID, SELECT-DYNAMIC-ID # NAME DYNAMIC-ID SELECT-DYNAMIC-ID 1 id-1 10.10.10.9 only-static only-loopback only-vrf only-active lowest
I just experienced the same problem. I upgraded hAP ax2 from 7.9 to 7.9.1 on May 22. Today all WiFi clients all of a sudden were disconnected and can't reconnect. Nothing in the logs except for disconnect info. After reboot everything works fine.Hi,
I had another error login with WiFi on this "STABLE" 9.1. Ït has been reported as SUP-116195. Mobile can not join WiFi mobile say the password is not correct and after reboot all is OK and mobile can join the WiFi without any chage. Im using only WPA/WPA2.
Export the config, netinstall, re-import. It's the savest and easiest way. :-)Hey guys, my RB4011 ARM is failing to upgrade, it downloads the package reboots, but then it's on 7.9 again.
Any idea how to fix it?
That seems quite the hassle, I think I'll wait for the stable of 7.10 and see if an upgrade works.Export the config, netinstall, re-import. It's the savest and easiest way. :-)Hey guys, my RB4011 ARM is failing to upgrade, it downloads the package reboots, but then it's on 7.9 again.
Any idea how to fix it?
Did you send supout.rif?I just experienced the same problem. I upgraded hAP ax2 from 7.9 to 7.9.1 on May 22. Today all WiFi clients all of a sudden were disconnected and can't reconnect. Nothing in the logs except for disconnect info. After reboot everything works fine.Hi,
I had another error login with WiFi on this "STABLE" 9.1. Ït has been reported as SUP-116195. Mobile can not join WiFi mobile say the password is not correct and after reboot all is OK and mobile can join the WiFi without any chage. Im using only WPA/WPA2.