Thu May 17, 2018 10:35 pm
Can you post your config?
We've got SXTs in wireless client mode running dhcp server for a hAP AC inside the home in bridge mode (all interfaces bridged} and it works fine.
I don't recall making and special changes to the bridge to make it work. Do an export and I'll see if anything looks amiss.
Here is a script I use, Very tight so it fits in flashfig. DHCP server not enabled at this point as it screws up provisioning.
At that stage they both get dhcp from the prov router
{{
:global model [/system resource get board-name ];
:全球e[国际米兰face ethernet print count-only where name~"ether"];
:global w [/interface wireless print count-only where name~"wlan"];
:global s [/interface ethernet print count-only where name~"spf"];
:global c [/interface ethernet print count-only where name~"combo"];
:global t;
:global p;
/system script {
add name=swbridge source={:global t; :global p;:if ($p != "e") do={:while ($p >0) do={/interface bridge port add bridge=Switch-Bridge interface=[($t.$p)];:set $p ($p-1)}}} policy=read,write
};
:local bridge do={/system script run swbridge};
/interface {
ethernet{
set [/interface ethernet find default-name~"ether" ] disabled=no;
set [/interface ethernet find (default-name~"combo") or (default-name~"sfp-sfpplus")] l2mtu=9000 mtu=2000 disabled=no
}
};
:if ($model="SXT HG5 ac" or $model="SXTsq 5 ac" ) do={
/interface {
wireless security-profiles {
set [find name="default"] authentication-types=wpa2-psk management-protection=allowed mode=dynamic-keys comment=default wpa2-pre-shared-key=REDACTED;
add authentication-types=wpa2-psk comment=REDACTED management-protection=allowed mode=dynamic-keys name=gcet-res wpa2-pre-shared-key=REDACTED
};
bridge {
add name=NAT-Gateway disabled=no;
port {
add bridge=NAT-Gateway interface=ether1
}
}
};
/ip dhcp-client {
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=wlan1
}
};
:if ($model="hAP ac" or $model="CCR1009-7G-1C-1S+") do={
/interface bridge {
add name=Switch-Bridge auto-mac=yes disabled=no;
:set $t "ether"; :set $p $e; $bridge;
:set $t "wlan"; :set $p $w; $bridge;
:set $t "spf"; :set $p $s; $bridge;
:set $t "combo"; :set $p $c; $bridge;
};
/ip dhcp-client {
add comment=provision dhcp-options=hostname,clientid disabled=no interface=Switch-Bridge
}
};
/system script remove swbridge
}}