as you know, since 15 may in Ukraine forced blocking russian websites, such as:
- social network vk.com
- social network odnoklassniki.ru
- all services Kaspersky Lab
- all services Mail.Ru
- all services Yandex
- and more others
I try to use Policy Based Routing:
Step 1.Created adress-list for blocked sites, example
Code:Select all
/ip firewall address-list add address=87.240.128.0/18 list=vkcom add address=93.186.224.0/20 list=vkcom add address=95.142.192.0/20 list=vkcom add address=95.213.0.0/17 list=vkcom add address=185.32.248.0/22 list=vkcom add address=95.213.0.0/18 list=vkcom add address=95.142.207.0/24 list=vkcom add address=95.142.206.0/24 list=vkcom add address=95.142.204.0/23 list=vkcom add address=95.142.203.0/24 list=vkcom add address=95.142.202.0/24 list=vkcom add address=95.142.201.0/24 list=vkcom add address=95.142.200.0/21 list=vkcom add address=95.142.192.0/21 list=vkcom add address=93.186.232.0/21 list=vkcom add address=93.186.224.0/21 list=vkcom add address=185.32.251.0/24 list=vkcom add address=185.32.250.0/24 list=vkcom add address=185.32.248.0/23 list=vkcom add address=185.29.130.0/24 list=vkcom
example
Code:Select all
/ip firewall mangle add action=mark-routing chain=prerouting comment="Mark vk.com" dst-address-list=vkcom new-routing-mark=Traffic_vkcom passthrough=no src-address=192.168.106.0/24
Step 3.Added new VPN client connection to server outside Ukraine
example
Code:Select all
/interface pptp-client add comment="VPN Failover" connect-to=uk.superfreevpn.com disabled=no name=pptp-to-freevpn password=1891 user=free
Step 4.Activated masquerade for new vpn-interface
Code:Select all
/ip firewall nat add action=masquerade chain=srcnat out-interface=pptp-to-freevpn
Code:Select all
/ip route add comment="Route VK.COM" distance=1 gateway=pptp-to-freevpn routing-mark=Traffic_vkcom
All added resources work, passing throuth VPN-connection, but too slowly. What i do wrong? Direct VPN-connection from PC work fine (all traffic), throubles only when use mikrotik and routing marks.
- Try change magle to passthrough=no/yes - no result, slow opening web-pages.
- As client RB951Ui-2HnD, internet connection symmetrical 80 Mbits, CPU avg. 1-7%;
- As remote VPN L2TP-server RB750Gr3, internet connection 80/5 Mbits, CPU avg. 0-1%
Any ideas?