I have a weird issue with spanning tree on RouterOS 7.3.1: I have a bridge set up on a CRS328, and a bridge on an RB760iGS (hEX S). The CRS328 has ether1 linked to the RB760's ether1.
CRS328 bridge:
Code:Select all
/interface bridge add frame-types=admit-only-vlan-tagged name=unibridge priority=0 protocol-mode=mstp vlan-filtering=yes /interface bridge port add bridge=unibridge frame-types=admit-only-vlan-tagged interface=sfp-sfpplus1 add bridge=unibridge frame-types=admit-only-vlan-tagged interface=ether1 pvid=100 /interface bridge vlan add bridge=unibridge tagged=unibridge,sfp-sfpplus1 vlan-ids=1 add bridge=unibridge tagged=sfp-sfpplus1,ether1 vlan-ids=5 add bridge=unibridge tagged=sfp-sfpplus1,ether1 vlan-ids=100
RB760 bridge:
Code:Select all
/interface bridge add frame-types=admit-only-vlan-tagged name=unibridge priority=0x1000 protocol-mode=mstp vlan-filtering=yes /interface bridge port add bridge=unibridge frame-types=admit-only-vlan-tagged interface=ether1 pvid=100 add bridge=unibridge frame-types=admit-only-untagged-and-priority-tagged interface=ether2 pvid=5 /interface bridge vlan add bridge=unibridge tagged=unibridge,ether1 vlan-ids=100 add bridge=unibridge tagged=ether1 untagged=ether2 vlan-ids=5
When attached to the RB760, I lose connectivity after a few seconds with the following in the CRS328's log (when topics=stp is enabled):
Code:Select all
03:16:03 bridge,stp ether1:0 learning 03:16:03 bridge,stp ether1:0 discarding 03:16:05 bridge,stp ether1:0 learning 03:16:05 bridge,stp ether1:0 discarding 03:16:07 bridge,stp ether1:0 learning 03:16:07 bridge,stp ether1:0 discarding
If I swap out the RB760 for an hAP-AC^2 with an identical bridge config, everything works as expected. I've erased, netinstalled, reset and reconfigured the RB760 so many times now I'm not being objective and probably missing something blindingly obvious. I've consulted the block diagrams and as far as I can tell, thisshouldwork.
If I disable MSTP on the RB760, connectivity returns and the CRS328 logs the following:
Code:Select all
03:16:09 bridge,stp ether1:0 learning 03:16:11 bridge,stp ether1:0 forwarding
If I swap out the RB760 for an hAP-AC^2 and leave MSTP enabled,the issue goes away and MSTP works fine.
I'm rummaging around now to see if I have another MMIPS board with a switch chip to see if it's architecture-specific. In the mean time, can anyone spot my obvious mistake?
(Some while later): Tried with an RBM33G and the exact same bridge config - this is also causing the CRS328 to spit out thelearning, discarding, learning, discardingloop, so based on a sample size of two, is this MMIPS-specific?
EDIT: Is this endian-specific? Next test this evening is to try the two MMips boards against each other and see if they work...
Thanks!