Sam, this is brilliant news. I really look forward to this. If you need a beta tester, just shout.we are adding the ability to update opendns when we receive a ddns update. we already have this built into our windows client. we plan on getting that working on the mikrotik ddns update script (server side) shortly. There will be a place within your account on changeip.com that will let you setup the auxillary update to opendns.
First upgrade to an authentic version, then ask questions.i have mikrotik 2.9.27
Sam, any news on this? I see OpenDNS have launched their Enterprise content filter and I'd like to sell this service but I need routeros/changeip/opendns to all work together.okay okay... i will try to make this a higher priority for us. We will relay an update to opendns upon an update to changeip.com ddns. however, i need to clear this with them first as they would start seeing a lot of updates coming from our single network. need to make sure its okay.
I also need the option to schedule this:realy i need this script
# DNSoMatic automatic DNS updates # User account info of DNSoMatic :global maticuser "GmailAccount" :global maticpass "PWD" :global matichost "" # No more changes need :global previousIP # Print values for debug :log info "DNSoMatic: Updating dynamic IP on DNS for host $matichost" :log info "DNSoMatic: User $maticuser y Pass $maticpass" :log info "DNSoMatic: Last IP $previousIP" # get the current IP address from the internet (in case of double-nat) /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html" :local result [/file get dyndns.checkip.html contents] # parse the current IP result :local resultLen [:len $result] :local startLoc [:find $result ": " -1] :set startLoc ($startLoc + 2) :local endLoc [:find $result "
" -1] :global currentIP [:pick $result $startLoc $endLoc] :log info "DNSoMatic: IP actual $currentIP" # Touching the string passed to fetch command on "src-path" option :local str "/nic/update?hostname=$matichost&myip=$currentIP&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG" :if ($currentIP != $previousIP) do={ :log info "DNSoMatic: Update need" :set previousIP $currentIP :log info "DNSoMatic: Sending update $currentIP" :log info [ :put [/tool fetch host=MT user=$maticuser password=$maticpass mode=http address="updates.dnsomatic.com" src-path=$str dst-path=$matichost]] :log info "DNSoMatic: Host $matichost updated on DNSoMatic with IP $currentIP" } else={ :log info "DNSoMatic: Previous IP $previousIP and current $currentIP equal, no update need" }
but u must gohttps://www.dnsomatic.com/account/and put ur open info
:delay -- time interval (default 1 second)