:delay 5s
You could use an RB750UP, which has 4 POE out ports.http://routerboard.com/RB750UP做坡喷油器的供电都长长吗ns? I may need to do a back-to-back AP scenario and would prefer to power both APs from 1 injector/power supply.
Divide by 1048576 (which is 1024 * 1024). One thing to keep in mind is that RouterOS will round to whole numbers, so doing something like 3000000/1048576 = 2.how can I convert "downbyte " to MiB???
:local downMB ($downbyte / 1048576)
:global running :if ($running != true) do={ :set running true ... script content here :set running false }
/interface/wireless/set =ssid=mikro_test =.id=wlan1
Use print command instead.When I attempt a straight export to file, I don't get the counters.
/queue simple print stats file=queueStats
document.sendin.username.value = document.login.username.value;
document.sendin.username.value = document.login.username.value.trim();
:global myVar
/system resource print /system resource print oid
/tool user-manager user print where name="JohnDoe"
/tool user-manager user print where name~"John"
It is actually referring to the item name instead a number.The only thing I missed what "=number" means in case of "get"? There is no such parameter in list of profile properties.
/tool user-manager database save name=$bbddfile overwrite=yes
/ip hotspot user remove [find name="userName"]
/ip hotspot user profile remove [find name="profileName"]
I can't seem to find any documentation or posts about this addition. What exactly is this?What's new in 6.19 (2014-Aug-26 14:05):
*) console - added unary operator 'any' that evaluates to true if argument
/ip hotspot user :foreach i in=[find] do={ :local name [get $i name] :if ($name != "Jone" && $name != "rayan") do={ reset-counters $name } }
:if ([:len $var] = 0) do={ ... your code here }
What does the SMS text look like that you are receiving?I just need something to handle spaces in sms text...
:log info [:resolve www.google.com]
/user set admin password=abc123
/ip firewall filter add in-interface=("!" . $hsinterface) dst-port=53 protocol=udp place-before=1 action=drop
/queue tree print where max-limit="1351000"
/queue tree :foreach i in=[find max-limit=1351000] do={ :put [get $i name] }
print where action="accept"
:put [/ip route find dst-address=0.0.0.0/0 and !routing-mark~""]
/ip firewall nat set [find comment="vlan 2 (Public Area 2)"] to-addresses=*.*.*.4 set [find comment="vlan 3 (Public Area 3)"] to-addresses=*.*.*.5
Yep, either one will work.So, I could put that command in a script or put it in the event area of a schedule?
/system reset-configuration run-after-reset=Something.rsc
/system scheduler remove [find name="00:0C:42:12:34:56"]
/system ntp client set primary-ntp=[:resolve 0.asia.pool.ntp.org]
/interface virtual-ethernet set [find name=vif1] name="name"
:if ([:len [/interface wireless registration-table find wds=no]] > 0) do={/log warning message="connected"} else={:log warning message="not conneced"}
/tool e-mail send to="xxxx@xxxx.com" from="from@domain.com" subject=...
/ip proxy access;:foreach i in=[find action=deny] do={:put [get $i dst-host]}
:if ([/interface get ether9 running] = false) do={ /log info "ether9 is not running" /do something else }
Yes, if you paste the script in my previous post into the terminal (or via telnet/SSH) it will add the netwatch item. Before you paste it, make sure and edit the script with the correct host=X.X.X.X IP address of your gateway.Copy paste in the terminal?
:local date ([:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . [:pick [/system clock get date] 7 11]);
/tool fetch url="http://ip_address/control.cgi\?bitrate...."
:global myVar "some value" ... ... /system script environment remove myVar
/system script environment remove [find]
:if ([/system resource get version] > 5.11) do={ :global runExport [:parse "/export compact"]; } else={ :global runExport [:parse "/export"]; } $runExport;
Enjoyed the article, thanks.
LOL, I feel your pain, been shocked by a few of those myself.An electric fence shock in the small of your back can make you nauseous
/tool user-manager user remove [find]
I assume you're referring to the script itself to which I agree. I think the script will be rebooting unnecessarily too often.while(true) is generally not a good idea.
/ip firewall filter remove [find]
:put [/system resource get version] :put [/ip hotspot user get [find name=david] uptime]
:local myFile "hotspotCookies.txt"; :if ([:len [/file find name=$myFile]] = 0) do={ /file print file=$myFile; :delay 2s; } /file set $myFile contents="$[:len [/ip hotspot cookie find]]"
/log print where time>([/system clock get time] - 5m)